C2H6's blog

bukan blog pelajaran kimia !!!!!!!

DESAIN DAN IMPLEMENTASI JARINGAN BERBASIS INTER-VLAN

Pada konsep intervlan routing kita masih menggunakan vlan, vtp, dan juga spanning tree protocol. Namun perbedaannya kali ini adalah kita akan menghubungkan antara switch dengan router dengan memakai konsep vlan, vtp, dan juga spanning tree protocol.

Adapun fungsi intervlan routing adalah kita bisa saling berkomunikasi antar vlan. Karena data yang kita kirim berbeda vlan akan di routing terlebih dahulu, kemudian diteruskan ke alamat host yang di tuju. Adapun hal ini dilakukan karena routing hanya meneruskan paket data, bukan menyebarkan paket data atau broadcast untuk menemukan alamat tujuan dari data tersebut. Jadi dengan kata lain tidak menyebabkan pemborosan bandwith.

Berikut contoh desain dan  implementasi inter-vlan :

Image

  • Isikan semua IP, subnet mask, dan default gateway PC dan server

PC

IP

Subnet Mask

Default Gateway

1

192.168.2.11 255.255.255.0 192.168.2.1

2

192.168.3.12 255.255.255.0 192.168.3.1

3

192.168.4.14 255.255.255.0 192.168.4.1

4

192.168.4.13 255.255.255.0 192.168.4.1

5

192.168.3.15 255.255.255.0 192.168.3.1

6

192.168.2.16 255.255.255.0 192.168.2.1

7

192.168.3.17 255.255.255.0 192.168.3.1

8

192.168.4.18 255.255.255.0 192.168.4.1

Server

192.168.40.254 255.255.255.0 192.168.40.1
  • Konfigurasi pada Switch 1

S1(config)#vlan 99

S1(config-vlan)# name rizky

S1(config-vlan)#ex

S1(config)#vlan 2

S1(config-vlan)#name akbar

S1(config-vlan)#ex

S1(config)#vlan 3

S1(config-vlan)#saputra

S1(config-vlan)#ex

S1(config)#vlan 4

S1(config-vlan)#name kyky

S1(config-vlan)#ex

S1(config)#interface range fastEthernet 0/1 – 5

S1(config-if-range)#switchport mode trunk

S1(config-if-range)#switchport trunk native vlan 99

S1(config-if-range)#ex

S1(config)#interface range fastEthernet 0/6

S1(config-if)#switchport mode access vlan 2

S1(config-if)#switchport access vlan 2

S1(config-if)#ex

S1(config)#interface fastEthernet 0/7

S1(config-if)#switchport mode access

S1(config-if)#switchport access vlan 3

S1(config-if)#ex

S1(config)#interface fastEthernet 0/8

S1(config-if)#switchport mode access

S1(config-if)#switchport access vlan 4

S1(config-if)#ex

S1(config)#vtp mode server

S1(config)#vtp domain rahasia

S1(config)#vtp password rahasia

S1(config)#int fa vlan 99

S1(config-if)#ip add 172.168.99.11 255.255.255.0

S1(config-if)# no sh

S1(config-if)#ex

S1(config)#ip default-gateway 172.168.99.1

  • Konfigurasi pada Switch 2

S2(config)#vlan 99

S2(config-vlan)# name rizky

S2(config-vlan)#ex

S2(config)#vlan 2

S2(config-vlan)#name akbar

S2(config-vlan)#ex

S2(config)#vlan 3

S2(config-vlan)#saputra

S2(config-vlan)#ex

S2(config)#vlan 4

S2(config-vlan)#name kyky

S2(config-vlan)#ex

S2(config)#interface range fastEthernet 0/1 – 5

S2(config-if-range)#switchport mode trunk

S2(config-if-range)#switchport trunk native vlan 99

S2(config-if-range)#ex

S2(config)#interface range fastEthernet 0/6

S2(config-if)#switchport mode access vlan 2

S2(config-if)#switchport access vlan 2

S2(config-if)#ex

S2(config)#interface fastEthernet 0/7

S2(config-if)#switchport mode access

S2(config-if)#switchport access vlan 3

S2(config-if)#ex

S2(config)#interface fastEthernet 0/8

S2(config-if)#switchport mode access

S2(config-if)#switchport access vlan 4

S2(config-if)#ex

S2(config)#vtp mode client

S2(config)#vtp domain rahasia

S2(config)#vtp password rahasia

S2(config)#int fa vlan 99

S2(config-if)#ip add 172.168.99.12 255.255.255.0

S2(config-if)# no sh

S2(config-if)#ex

S2(config)#ip default-gateway 172.168.99.1

  • Konfigurasi pada Switch 3

S1(config)#vlan 99

S1(config-vlan)# name rizky

S1(config-vlan)#ex

S1(config)#vlan 2

S1(config-vlan)#name akbar

S1(config-vlan)#ex

S1(config)#vlan 3

S1(config-vlan)#saputra

S1(config-vlan)#ex

S1(config)#vlan 4

S1(config-vlan)#name kyky

S1(config-vlan)#ex

S1(config)#interface range fastEthernet 0/1 – 5

S1(config-if-range)#switchport mode trunk

S1(config-if-range)#switchport trunk native vlan 99

S1(config-if-range)#ex

S1(config)#interface range fastEthernet 0/6

S1(config-if)#switchport mode access vlan 2

S1(config-if)#switchport access vlan 2

S1(config-if)#ex

S1(config)#interface fastEthernet 0/7

S1(config-if)#switchport mode access

S1(config-if)#switchport access vlan 3

S1(config-if)#ex

S1(config)#interface fastEthernet 0/8

S1(config-if)#switchport mode access

S1(config-if)#switchport access vlan 4

S1(config-if)#ex

S1(config)#vtp mode client

S1(config)#vtp domain rahasia

S1(config)#vtp password rahasia

S1(config)#int fa vlan 99

S1(config-if)#ip add 172.168.99.13 255.255.255.0

S1(config-if)# no sh

S1(config-if)#ex

S1(config)#ip default-gateway 172.168.99.1

  • Mengkonfigurasi Router

R1(config)# line console 0

R1(config)# password rahasia

R1(config)# login

R1(config)#enable secret rahasia

R1(config-line)#ex

R1(config)#interface fastEthernet 0/1

R1(config-if)#ip add 192.168.40.254 255.255.255.0

R1(config-if)#no sh

R1(config-if)#exit

R1(config)#interface fastEthernet 0/0.1

R1(config-subif)#encapsulation dot1Q 1

R1(config-subif)#ip add 192.168.1.1 255.255.255.0

R1(config-subif)#exit

R1(config)#interface fastEthernet 0/0.2

R1(config-subif)#encapsulation dot1Q 2

R1(config-subif)#ip add 192.168.2.1 255.255.255.0

R1(config-subinf)#exit

R1(config)#interface fastEthernet 0/0.3

R1(config-subif)#encapsulation dot1Q 3

R1(config-subif)#ip add 192.168.3.1 255.255.255.0

R1(config-subinf)#exit

R1(config)#interface fastEthernet 0/0.4

R1(config-subif)#encapsulation dot1Q 4

R1(config-subif)#ip add 192.168.4.1 255.255.255.0

R1(config)#interface fastEthernet 0/0.99

R1(config-subif)#encapsulation dot1Q 99 native

R1(config-subif)#ip add 192.168.99.1 255.255.255.0

R1(config-subinf)#exit

March 27, 2013 - Posted by | IT | , , ,

No comments yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: